Community Forums Archive

Go Back

Subject:SF 11 Windows 10 Administrator Privileges
Posted by: sophocles
Date:10/10/2015 8:59:28 AM

SF 11 is has started requiring Administrator privileges to run. I've re-read thru other posts regarding this issue. It's a problem I've encountered before with earlier versions, and various OS iterations. It's not a new problem, but it is a problem which intermittently but persistently appears.

I don't want to turn UAC off, and I don't want to run the program as administrator - running it as administrator changes the way some specialized mouse button settings work - as in, they don't - when I run as admin.

The problem appears to be related to a helper app, ApplicationRegistration.exe, located in the SF program folder. It is, I think, a certificate, or something that examines the Sony certificate for SF.

If you click Next on the dialog that pops up, you can then click "Show information about this publisher's certificate" When I do that, under the General tab of the next dialog that pops up, I see that the Valid From dates are from 9/18/2012 to 10/9/2015. Well, 10/9/2015 was yesterday, so I no longer have a valid certificate.

I'm guessing the ApplicationRegistration.exe app is supposed to keep this updated, but for some reason isn't working right.

Anyone have any thots on this?


Subject:RE: SF 11 Windows 10 Administrator Privileges
Reply by: donaldh606
Date:10/15/2015 2:07:44 PM

Hi Sophocles, have you tried this?

Go Back