Community Forums Archive

Go Back

Subject:MIDI Editing Oddities
Posted by: Musition
Date:11/24/2014 12:49:55 AM

So this is more of an annoyance than a problem. Many times when I have inline-editing enabled for a MIDI track, I'll usually double-click the piece of MIDI data to edit its velocity. More times than not, the editing won't "take" if you will. What I mean is, if I draw some MIDI data, the velocity defaults to 64. I would often enter a higher number. I would play it back. It would sound just as soft as before. I would double-click it again to find out that the velocity had never been changed. Sometimes I have to double-click twice, sometimes it "takes" on the first try, and sometimes I have to do it four times! I mostly use MIDI for drums, but I found out it also does it for synths.
I don't have this problem if I right-click and use the Velocity -> Set to... menu. That's why I'm not terribly bothered by this, but I am wondering if this happens to anyone else.

Message last edited on11/24/2014 2:01:37 AM byMusition.
Subject:RE: MIDI Editing Oddities
Reply by: johnsawan79
Date:11/24/2014 1:01:09 AM

I encountered the same issue, a day ago after setting the new value then getting back to it I find the values unchanged. I think there's another way around, look in the "View" menu, i think there's an option to see the velocity like vertical lines with diamond shaped tips which you can adjust by dragging it up & down. I cant remember the name of the function but its there just look somewhere near at the bottom options.

Subject:RE: MIDI Editing Oddities
Reply by: Musition
Date:11/24/2014 1:45:04 PM

That's true, I tend to forget about using the velocity stems. It's mostly because they tend to make the MIDI event very "busy", but I may give them another shot.

Subject:RE: MIDI Editing Oddities
Reply by: pwppch
Date:11/24/2014 4:38:01 PM

I can reproduce this behavior if I enter the velocity value and then click away from the edit box.

If I hit enter or tab to close the edit, the change is made.

I would say it is a bug, but there are work arounds short of using the velocity stems.


Message last edited on11/24/2014 8:28:02 PM bypwppch.

Go Back