Community Forums Archive

Go Back

Subject:Markers Question
Posted by: scott2eh
Date:10/16/2013 9:57:41 PM


I've had this problem at least since v 10 maybe earlier, so maybe I just don't understand how it is supposed to work.

When I am listening to a song (playing) and hit the letter M a marker is created. However, it happens in 2 different ways and I can't figure out why.

Sometimes it puts the marker exactly where the cursor is, ie exactly the point of the song I'm hearing right now. BUT, other times it puts it at the last place where I clicked. I can't figure out why it chooses to put it one place or the other. Is there an explanation for this?

Or, is there a way I can have it always put the marker exactly where the cursor is while playing? I can't think of any reason why I'd want the marker to go any place else!

And a second problem I'm pretty sure I've mentioned before: When I drag a section of a song into another data window (as I do all the time when editing) why does a new marker appear at a random spot after the edit point? Can I turn that off? It's extremely confusing!!


Subject:RE: Markers Question
Reply by: Chienworks
Date:10/17/2013 11:40:25 PM

I've seen this before and it can be frustrating. I haven't decided exactly what the mechanisms are that makes it stop tracking the moving cursor, but i'm pretty sure touching the scroll bar is one of them. However, there is a solution. Assuming you always want it to mark the current cursor position, press the \ (backslash) key before setting the marker. This forces Sound Forge to go back to tracking the cursor if it wasn't. The marker will then place at the current cursor position.

Subject:RE: Markers Question
Reply by: J.
Date:10/18/2013 3:37:36 PM

Scrolling with the scrollbar disables autoscroll (if Options->Scroll Playback is checked) and re-enables the edit cursor. In this case, the marker will be dropped at the edit cursor position instead of the playback position.

If you have additionally unchecked Options->Seek Cursor on Playback, you'll get this same behavior once you click or otherwise change the edit position/selection. Playback continues, but the view stops scrolling.

Seems reasonable to assume that if a user changes view or selection while playing back, what they are viewing or selecting is more interesting to them than the playback position, hence the marker drop behavior.

But, as noted, you can always "re-hide" the edit cursor and start autoscrolling the playback position with the Edit->Center Cursor command (numpad *, backslash, or period by default).

Also, if you do not want metadata to tag along with your drag mix/paste operations, you can disable Options->Lock To Selection (v11) or Options->Paste Markers/Regions (prior versions).


Message last edited on10/18/2013 3:46:08 PM byJ..

Go Back