Community Forums Archive

Go Back

Subject:Batch conversion and saving troubles
Posted by: Trev Wilkins
Date:12/17/2010 2:55:16 AM

I've just used Batch Converter (10.c) to convert several folders of mono files into 8-bit files for ansaphone messages. On checking these files there appears to be extra audio added to the end of some of the files, about a syllable from the last word is added onto the end.

I thought that for speed I would just go through them all and edit the endings but hit another problem. I'd highlight the offending bit, hit Ctrl-X to cut it and it would disappear. Then I'd click the save icon and it would reappear! I've closed and restarted SF and this behaviour cointinues.

I have also noticed that the 'Open' dialog box shows the files as 8 bit correctly but once opened the lower right text shows them as 16 bit (incorrectly).

Can anyone reproduce this?

I'll file a report when I have time.

Subject:RE: Batch conversion and saving troubles
Reply by: Trev Wilkins
Date:12/17/2010 4:27:28 AM

I've done some more work on this and it's extremely frustrating as our client is waiting for these files. It appears that it's not down to Batch Coinverter as simply saving in the same format also adds random extra audio.

The specs I'm saving as are as follows...

8 Bit Mono

Every time I save in this format it adds to the file.

Any help would be gratefully received.


Subject:RE: Batch conversion and saving troubles
Reply by: Trev Wilkins
Date:12/17/2010 4:58:38 AM

Yet more investigation seems to point to the specific format causing the problem and I think it may be the CCITT A-Law format that causes it.
I've saved a file using Windows Sound Recorder and this also adds extra at the end.


Subject:RE: Batch conversion and saving troubles
Reply by: Trev Wilkins
Date:12/17/2010 5:23:23 AM

Success at last!
It seems that the info from the knowledgebase that applies to U-Law also applies to A-Law. For anyone else who needs to know here it is...

This is a classic case where the General preferences checkbox "Ignore fact chunk when opening compressed WAV files" should NOT be checked. Uncheck it and reload the file you should notice now that the glitch is gone.

How this works:

The 'fact' chunk is a RIFF tag that is stored in the WAV file. It contains a value that is the number of valid data points in the entire file when decoded. If WAV ignores this, you'll see some garbage at the end of the last buffer of decoded data for some compression formats, such as u-Law. If WAV pays attention to the fact chunk, the extra bytes after the end of the last decoded sample in the buffer are ignored. Whether there is extra garbage in the decode buffer is dependent on the decoder. A better written decoder would either zero the remaining samples after the last decoded sample to the end of the buffer, or it would indicate the correct number of decoded samples when the decode buffer is only partially filled. However, the u-Law codec is not ours, it is usually included when Windows is installed.

The reason the checkbox isn't always unchecked by default is there are some applications that improperly author files and do not set the 'fact' chunk to the correct value. As a result, the file may be cut off at the end or appear to contain 0 samples. The "Ignore fact chunk" preferences is checked by default so that user data is never cut off.


Subject:RE: Batch conversion and saving troubles
Reply by: sglickster
Date:5/30/2011 7:08:33 PM

Thanks for the work you've done on this issue. I have a similar problem, which persists even after making the change from you 12/17 post (clearing "Ignore fact chunk . . .). I edit a .wav file and save it in this format:
8 hz
I see the next time I open the file, though, that it was saved as U-Law, 8 Hz, 16-bit. I haven't been able to figure out any technique to save the file as 8-bit (required by the PBX I'm working with). Have you or anyone run across any solutions to this problem?
Much thanks,

Subject:RE: Batch conversion and saving troubles
Reply by: roblesinge
Date:6/5/2011 11:37:25 AM

The files are 8-bit. SF interprets them as 16-bit. If you look in Windows at the specs listed in file properties, it should say 8-bit. A-Law files are by definition 8-bit files, no matter what the computer is telling you. Are you having trouble using them in the PBX?


Message last edited on6/5/2011 11:37:47 AM byroblesinge.

Go Back