Community Forums Archive

Go Back

Subject:Bug? Dragging VST to Mixer Crash
Posted by: pHuNzOnE
Date:12/2/2008 6:46:58 PM

I think this is a bug ... but maybe an unincorporated feature.

From the mixer panel you can insert VSTs by using the little green icon (same one from track view) or by right clicking on the Insert part of the panel to get to the drop down menu.

I also tried to 'drag and drop' a VST from the Plugin Manager window and drop it on the Insert panel part of the mixer on a specific track. While dragging the VST it went from the 'slashed zero' mouse pointer to the 'plus sign with a little document' when I dragged it on to the mixer track ... seemingly indicating that this was a proper place to release or 'drop' the 'document.' I released it and it looked like it was trying to load the VST ... then 'poof!' the application crashed. I've repeated this behavior several times ... but never had it successfully load ... just got the crashes.

Since I don't know if this is supposed to be a feature or not, I don't know if it's a bug. It would certainly be very handy to be able load VSTs by 'drag and drop' ... so I hope it's a bug that can be fixed.


Subject:RE: Bug? Dragging VST to Mixer Crash
Reply by: pwppch
Date:12/2/2008 11:03:32 PM

I have been trying to reproduce this problem and have been unable to.

Does this happen with any VST (or DX?) plug-in?

Can you tell me one or two specific VST plug-ins that cause this to always happen? (Or even happen once and a while?)


Subject:RE: Bug? Dragging VST to Mixer Crash
Reply by: pHuNzOnE
Date:12/7/2008 3:03:52 PM

Hi Peter ...

Sorry it took me so long to get back. I tried this again on an empty project and it worked fine. The times it has crashed was on a pretty full blown project with a dozen plus tracks and a couple of multitimbral VSTis, namely StylusRMX and Kontakt, instantiated.

In the later case it didn't seem to matter what the plug in was ... it even happened with Sony Track EQ. I should add that I didn't build the project that way, i.e., by dragging and dropping. I tried to drag and drop when I couldn't find the plug I wanted in the drop down menus on the mixer page.

Maybe you could grab a large project you have somewhere and check this out further. BTW I was still able to add plugs the old fashioned way or with the drop downs after I recovered from the crashes. So it wasn't that I was at an upper limit. I do note that just before the crash on all occasions an ominous total white screen appeared within the window with only the window title bar remaining legible ... then 'poof!'.

In the meantime I've checked most of the manufacturer's folders to show in the drop downs and this works pretty well. Not really interested in pressing my luck and blowing out the app. Sometimes ... as you probably know ... all the VSTi settings get lost on a crash.


Go Back