Community Forums Archive

Go Back

Subject:Desperate quadcore woes :-(
Posted by: alltheseworlds
Date:7/26/2008 9:17:32 PM

I've reached that famous "ripping hair out" stage. My new quadcore just keeps clicking and popping with AcidPro 6d b363. I'll be running at just 4% capacity at 8ms with *one* synth running and it'll pop every 10 to 40 seconds !

9450quad on an Asus P5K-e
4Gb Corsair 4-4-412 ram
Gigabyte Geforce 8600 GT fanless video
Three Seagate Barracuda SATA drives
XP Home SP3

The audio card is an M-Audio 24/96 as my much-loved Pulsar-II won't fit on the board !

Here's what I've tried:
- background priority
- file indexing off on all drives
- power management off
- system restore off
- defraged all drives
- disable all Windows eyecandy
- disable onboard LAN
- disable onboard audio
- disable floppy drive
- disable com port
- disabled avira
- disable CPU sidestep CPU control
- shifted PCI slots

I've also selectively disabled CD/DVD drives, USB, firewire port. I shut down all miscellaneous services so I'm down to 30 processes etc all to absolutely no effect.

I've run the DPC latency checker tool and I'm flatline all the way - a maximum of just 46us and I'm popping and clicking.

I've got the latest board BIOS, the latest M-Audio driver and reinstalled Acid.

Apart from disabling the LAN port (which affected DPC latency) nothing else seems to have had any effect at all. I've tried all sorts of enabled/disabled combinations. I think they're all really just 'tweaks' which aren't relevant to whatever it is that's giving the pops.

SoundForge 9e is working flawlessly. FL Studio seems to share Acid's problems, but my copy of Sonar 5pe is perfect (maybe because it's only running one core?)

I just can't think of anything more to do ..... I need to use Acid !

(message edited to add more details)

Message last edited on7/26/2008 11:47:45 PM byalltheseworlds.
Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:7/27/2008 6:26:18 AM

Just for comparison I loaded the exact same test instruments into -umm- Reaper and even at 256samples (5ms) it played flawlessly. The same project in Acid was crackle-mad.

Likewise FL Studio suffers a few underruns and ocassional pop, whereas Sonar 5pe is perfect.

What does it all mean ?!

Subject:RE: Desperate quadcore woes :-(
Reply by: jackn2mpu
Date:7/27/2008 10:50:21 AM

The synth your'e running: is it an Arturia one? Those tend to be processor hogs and can make noise for no particular reason when heavily used. Or are you using a sampler with a piano called up with a lot of notes being played? I've run into both these problems, albeit on a single core P4.

Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:7/27/2008 6:15:43 PM

Good thought, but it doesn't matter which ones I use. Mostly it's been Kontakt and the Korg Mono/Poly. But it happens with anything....

Subject:RE: Desperate quadcore woes :-(
Reply by: Greg_M
Date:7/27/2008 11:02:56 PM


Given the list of things you have already done, there are two things that you might try. The first one is easy. Run Microsoft's Dual Core Hotfix. It is supposed to be included with XP sp3, but it won't hurt to run it just to be sure. The next thing, and it is more likely the problem, is your video card/driver. If you have access to another video card, even an older one that you know has worked with your audio programs, it would be worth swapping out. I have seen/heard of many problems that sound like yours and the video card is often the culpret.

Hope this helps,

Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:7/28/2008 12:30:02 AM

Thanks Greg :-) I'll try the hotfix. I don;t have another compatible video card (plenty of old AGPs though!). I'll leave the replacement video card option until last since there's hundreds of users all over the net using Gigabyte 8600GT cards with their DAWs - it was one of the main reasons I chose this card. But you may well be right...

Subject:RE: Desperate quadcore woes :-(
Reply by: Douglas Clark
Date:7/28/2008 3:11:38 PM

Which version of Kontakt are you using?

Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:7/28/2008 4:47:30 PM

Version 2, but it doesn't matter if Kontakt is there or not. I've tried it with other vstis with the same effect :-( *sob*

Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:7/28/2008 10:42:29 PM

Well, I'm convinced this is an AcidPro problem. It clicks on a single audio loops with no VSTi playing.

But I can load VSTis in "standalone" mode outside Acid and they play fine - no clicks or pops at all.

That seems pretty conclusive to me. Can't be the soundcard, graphics card, faulty mobo etc. It's software.

But am happy to hear - any- opinions to the contrary as I really want to get Acid working.

Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:7/29/2008 12:18:53 AM

AcidPro is also crashing a lot. Always on the module ntdll

Is this a clue ?

Subject:RE: Desperate quadcore woes :-(
Reply by: Greg_M
Date:7/29/2008 11:19:48 PM


Don't forget that hardware needs software to run - Drivers. I don't have any trouble at all running ACID Pro on my Tyan Quad with either a Digi 002 rack or M-Audio Audiophile 192. ACID Pro is not likely your problem.

Have you tried uninstalling and re-installing ACID Pro? Do you have problems with the ASIO driver and the Wave driver? I gotta say, it sounds like a buffering issue. Try the uninstall and re-install.


Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:7/29/2008 11:20:01 PM

Just to continue my blog on the subject for the Googling pleasure of future unfortunates.....

I've tested all the RAM (fine)
Added the 3GB switch
Disabled Firewire completely
Reinstalled the latest video driver
Uninstalled 'soundmax' software from the mobo soundchip (even though it was disabled in the bios)

All this has made things marginally better in Acid, but am still getting pops.

On the other hand I can run 32-voices of loooong release synth in standalone mode @ 2ms latency with not the hint of a problem.

I can also play 40 tracks of simultaneous audio in Vegas 7b at 5ms with no pops. The CPU doesn't go higher than 6%.

Can any guru tell me what that means so far as troubleshooting Acid is concerned ?

Surely all this must narrow the range of possible problem areas ?

Does this machine really have a problem at all ?

Someone must have more ideas !!!!

Message last edited on7/29/2008 11:44:47 PM byalltheseworlds.
Subject:RE: Desperate quadcore woes :-(
Reply by: Greg_M
Date:7/31/2008 8:19:12 PM


Maybe I missed it, but did you uninstall ACID pro and re-install it. I have had personal experience with this fixing strange problems like yours. Since the other Sony programs seem to work just fine its not likely you have chipset problems or anything like that.

The other thing that I have seen create havoc are poorly written plug-ins. If you have any freeby VST's I would try removing them (at least temporarily). I have gone so far as to remove all of the non-Sony plugs and add them back in one by one until I find the one that is causing problems. By removing them I mean take them out of your VST folder so they don't load on startup of ACID.

Hang in there. You'll get it sorted out.

Good luck,

Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:8/1/2008 5:49:51 AM

Thanks Greg, you're a bright spot in a dark time. I've pulled out a few newer plugins. I did re-install Acid a few days ago (to no effect) but may try again after some more fiddling.

There are just so many variables to consider. Things seem to be a bit better now, but not where they should be. And, I have absolutely no idea what I've done that seems to have improved things.

On the other hand the ASIO driver of my M-Audio 24/96 completely disappeared today - just wouldn't show up in any audio app, but came back on a reboot. That makes me suspicious of the card, so I've ordered a Echo MiaMIDI to see if that changes anything.

I was hoping Peter (SonyPCH) might also turn up here and offer some advice, but no luck so far ....

Just got to keep going I suppose.

Subject:RE: Desperate quadcore woes :-(
Reply by: alltheseworlds
Date:8/8/2008 5:56:21 PM


After doing absolutely exhaustive system checks of all components, swapping out parts, testing RAM and drive integrity and speed, stripping out VSTis, replacing the soundcard, and paring down processes I have come to an important understanding: AcidPro 6 is the problem.

I can run other audio apps now with absolutey no problems or clicks even under heavy load.

Acid is still giving clicks even on light loads and has a tendancy to crash.

It's simply not compatible with my quadcore system. I suspect that the code is simply too and too buggy to robustly cope with the various system permutations of quadcore rigs.

When AcidPro 7 is released I might try the demo, but otherwise I'm back to Sonar (and dare I say) Reaper, both of which work flawlessly. And as much as I hate the Reaper fanboys, and have always maintained Reaper to be a ripoff of Acid, it seems to be everything that I had hoped AcidPro 7 might be !

It's a pity Sony doesn't like AcidPro as much as I do.


Go Back