Community Forums Archive

Go Back

Subject:Illegal System DLL Relocation
Posted by: Luckyzl230
Date:4/4/2007 6:32:34 AM

For some reason I got this message when starting my computer this morning. I remember that DLL thing comeing up a lot when my AP 6 crashes every now and then. Which it did last night too. But I've never recived this one before.
Can someone tell me if this is a Acid problem or a regular computer problem?

[RTHDCPL.EXE - Illegal System DLL Relocation]

{The system DLL user32.dll was relocated in memory. The application will not run properly. The relocation occurred because the DLL C:\WINDOWS\system32\HHCTRL.OCX occupied an address range reserved for windows system DLLs. The vendor supplying the DLL should be contacted for a new DLL.}

Subject:RE: Illegal System DLL Relocation
Reply by: pwppch
Date:4/4/2007 11:02:11 AM

I can't see how this relates specifically to ACID. It is not associated to the ReWire debug dialog that appears.


Subject:RE: Illegal System DLL Relocation
Reply by: vespesian
Date:4/5/2007 1:18:11 PM

That's actually a bug that's been showing up on some windows (2000, XP & Vista) systems that d/l'd the latest critical security update (animated cursor issue) from Microsoft over the last few days. If you google it, I think there's an (unoffical) fix floating around out there somewhere.

Subject:RE: Illegal System DLL Relocation
Reply by: Luckyzl230
Date:4/6/2007 10:03:29 PM

Yup! That was exactly it.
I had downloaded an update with google/Firefox not to long before that Error came up.
I restored my computer to an earlier date. Right after, it wanted me to download the update again, but I instead left it alone.
So far all is good.

Thanks :)

Subject:RE: Illegal System DLL Relocation
Reply by: bnmoore
Date:4/7/2007 12:29:58 AM

If you are referring to the KB925902 patch the KB935448 patch is supposed to fix what the first one broke. You can download the executable, you don't have to use Windows Update.

Subject:RE: Illegal System DLL Relocation
Reply by: MyST
Date:4/8/2007 9:16:36 AM

This isn't just an Acid thing. It's really weird what was affected. My CAD/CAM software worked fine until I tried to transfer my program from my PC to my Machine Tool.
There is indeed a fix for this, so you can download the latest security patch then install the fix for it.

Go Back