Community Forums Archive

Go Back

Subject:Playback Device Toolbar question...
Posted by: djroguescout
Date:6/18/2005 5:05:52 PM

First off SF8 is GREAT! Thanks for the new build as well.

I use SF with Acid 5 Pro and Pro Tools 6.7. Prior to updating to Version 8, I was able to create a toolbar for the Playback device and was able to switch between my Digi ASIO driver and my MS Soundmapper on the fly. This made comparing audio on my different sets of monitors (the speaker-type) a breeze.

One of the first things I set up with SF8 was putting that toolbar at the top. But now it seems to be "de-lighted" and inactive. I now have to go to the Preferences menu and switch it with the Audio Device Type pull-down. On the Audio Preference screen the Default Playback Device is grayed out as well.

I checked the Toolbar Preference menu and could not find a Playback Device option to add to the toolbar. Am I missing something here? It seemed okay in previous versions.

Is there a workaround or other setting I can use to get this toolbar active again? It seems strange to have a toolbar that cannot be selected in the main window.

(Visiting the preferences several times in a session is just a pain in the ***.)

Other than that, everything else is awesome with this program! Integration with Acid is smooth and easy! Yeee-ha!

Thanks in advance for any help you can provide.

And maybe some info here for your techies:

When I record into SF8 through my Shure KSM44/FMR Audio Pre and Comp/Digi Mbox combo... there is a noticeable noise floor and "over-brightness" that does not occur when running the same hardware and settings into Pro Tools. Obviously the Digi driver and AD convertor is friendlier to its own host software, but I was surprised in the difference in sound quality between the two. Night and day. Maybe your pros can figure that out.

Subject:RE: Playback Device Toolbar question...
Reply by: Iacobus
Date:6/19/2005 6:29:11 PM

Almost sounds like a driver problem. Did you try uninstalling and then reinstalling the drivers for your audio interface?

RodelWorks - Original Music for the Unafraid
Buy Instant ACID by JohnnyRoy and mD!
mD at ACIDplanet

Subject:RE: Playback Device Toolbar question...
Reply by: ForumAdmin
Date:6/20/2005 9:45:15 AM

Sound Forge 8.0 is the first version to support ASIO, so I expect you were switching between the Digi Wave driver and MS Sound Mapper in prior versions.

At any rate, the Playback Device field will be grayed out if there is only one device available for the current driver *type*, which is always the case with Microsoft Sound Mapper.

In order to get the behavior you want:
1) In Options->Preferences->Audio, set "Audio device type" to "Windows Classic Wave Driver" (or a specific ASIO device if you wish).

2) In Options->Preferences->Toolbars, check the "Play Device" entry.

As for the differences between SF and Pro Tools, make sure you're comparing apples to apples. Same driver (PT is likely using the ASIO driver), same bit-depth, sampling rate, and channels. If you are using the same device via Sound Mapper, then it is likely the MS Kmixer is getting involved for some type of format conversion.


Subject:RE: Playback Device Toolbar question...
Reply by: djroguescout
Date:6/23/2005 7:12:10 PM

Thanks for the replies!

Yeah... I already had the Toolbar shortcut figured out, but now I understand why it would be grayed-out for the Soundmapper. I am using the wave classic driver now and have an active shortcut.

As far as the noise-floor issue, I was recording in The Forge with the Digi ASIO driver, but using an outboard, decent quality pre and the "line" level on the M-Box to bypass its built-in pre.

So I thought, "screw-it", lets do this right!

I went out, bought a Groove Tubes Brick, ran the mic through it, and then out to the Mbox on the "Mic" level with its, "Psuedo-Focusrite Green Pre" turned all the way down. Voila! No noise on either program now! And it's all warm and fat now! Ahhhhh... God bless tubes! I haven't tried the line level yet, but I suspect that could be part of the issue.

I still don't know why I was getting noise only with Soundforge and not Pro Tools. It was like Pro Tools was able to compensate for and quiet the noise and Soundforge said, "Not so fast, buddy!"

Except both The Brick and my FMR pre send out balanced signals. The only difference is XLR vs. TRS. Well... and those 3 tubes!

As for Pro Tools, I upgraded to 6.9 today and of course hit another problem with The Forge. I'll post it in a new topic for your amusement.

Maybe I should flip Digi the bird and track with Acid!!

Thanks again for your help!

Go Back