Community Forums Archive

Go Back

Subject: Unable to open Sound Forge
Posted by: Caraelius
Date: 6/26/2013 7:23:39 AM

I have been using Soundforge Audio Studio 10 with Vegas Pro 12. (and Movie Studio 10) until recently on a Windows 7 Sony desktop pc and now on a Windows 8 Sony desktop pc. I had registered the software on both machines when Sony asked me to. For no apparent reason, I tried to open Soundforge today and cannot get any further than Sony asking me to register online. I get two screens suggesting I am being taken to register online then nothing. The programme won't open and I can't get online to register. So I found the repair online registration tool, installed that, but no change. I am unable to open the programme and can't get further than the second online registration screen. Can anyone help?

Subject: RE: Unable to open Sound Forge
Reply by: pwppch
Date: 6/26/2013 10:23:25 AM

Right click on the forge exe and select run as administrator.

If this works, then you can configure the forge exe to always run this way.

Peter

Subject: RE: Unable to open Sound Forge
Reply by: Caraelius
Date: 6/27/2013 2:01:27 AM

Thanks that works fine now. Just one point for others using Windows 8 with the Obit Start Button Menu - click on the start button and find Sound Forge in the list of programmes, right click and give the Obit Start Menu button the authority to open it, then run as administrator.
Thanks again for the quick advice
Margaret

Subject: RE: Unable to open Sound Forge
Reply by: Caraelius
Date: 6/27/2013 2:22:54 AM

Hi - sorry to come back again on this but the programme will open as a stand alone but won't operate as an audio editor with Vegas Pro 12. Is this a known problem?

Subject: RE: Unable to open Sound Forge
Reply by: rraud
Date: 6/27/2013 4:25:13 PM

Is SF designated as the default audio editor in Vegas? "Options> Preferences"

Message last edited on 6/28/2013 9:07:24 AM by rraud.
Subject: RE: Unable to open Sound Forge
Reply by: ECB
Date: 7/3/2013 9:49:31 AM

I also have a problem with Sound Forge opening properly and requesting registration again. I registered again but it did not solve the problem. I contacted support and they suggested running Sound Forge with full administrative privileges. Running SF with full administrative privileges solved the registration problem but created new problems. I can no longer open SF from within Vegas. To solve that problem support suggested I run Vegas with full administrative privileges. Running Vegas with full administrative privileges solved the opening Sound Forge from within Vegas but I could no longer drag and drop media on Vegas. Support has offered several other solutions but none have solved the problem so far. I addition I have found that running Sound Forge with full administrative privileges has a additional problem, I can no loner drag and drop media on Sound Forge. I have two machines that exhibit the same Sound Forge problem.

ed b

Subject: RE: Unable to open Sound Forge
Reply by: DTaylor
Date: 7/31/2013 12:13:42 PM

I am having exactly the same problems as Caraelius - I'm doing all the right things but Sony Forge still won't open sound clips from Vegas. Any advice for us?

Subject: RE: Unable to open Sound Forge
Reply by: DTaylor
Date: 7/31/2013 1:38:04 PM

I'm having a similar problem to you, ECB. I'm unable to open use Sound Forge in connection with Vegas. Running Vegas "as administrator" has resulted in all sound files on Vegas sounding completely fuzzy and garbled - permanently, it seems. Nightmare. Did you make any progress with tech support?

Message last edited on 7/31/2013 1:46:26 PM by DTaylor.
Subject: RE: Unable to open Sound Forge
Reply by: ECB
Date: 7/31/2013 10:11:06 PM

DTaylor,

No progress from support. I have not had any garbled audio files but I have been working with wav.

ed

Subject: RE: Unable to open Sound Forge
Reply by: pwppch
Date: 8/1/2013 5:15:07 AM

We are looking at the need to run as admin issue.

Peter

Subject: RE: Unable to open Sound Forge
Reply by: DTaylor
Date: 8/1/2013 5:59:21 AM

Thanks for looking into this. Just to be clear, the problems are:

1 - Sony Vegas and Sony Forge Studio are not working together.
This means I cannot edit sound on Vegas. I have set Sony Forge as my sound editor in "Preferences" - with no result, sound files simply will not open. I have tried running both Vegas and Forge Studio as administrator - no luck there either.

2 - Running Vegas as administrator has resulted in all sound on Vegas being fuzzy beyond recognition.
So far I have found no way to undo this. I have also tried uninstalling and reinstalling my Sony software - and unfortunately I am still experiencing the same problems.

I'd really appreciate some feedback as soon as you can - I'm under pressure to get this project completed fast.

Thank you.

Message last edited on 8/1/2013 5:59:46 AM by DTaylor.
Subject: RE: Unable to open Sound Forge
Reply by: ECB
Date: 8/1/2013 9:04:08 AM

Peter,

Thank you for looking into the need to run as admin issue.

Ed B

Subject: RE: Unable to open Sound Forge
Reply by: Larry Clifford
Date: 8/1/2013 4:54:06 PM

I am thinking of upgrading to Audio Master Suite (SF Pro 11 and Spectral Layers Pro 2). Will I have some of these problems?

When to install is not critical. Should I order now (before August 28), but wait to install when an update is available?

Larry

Subject: RE: Unable to open Sound Forge
Reply by: rraud
Date: 8/2/2013 9:29:21 AM

Not everyone experiences this issue.
"Should I order now (before August 28), but wait to install when an update is available?"
Sure , if it will save you a few bucks. You can install whenever you want, next week or next year, there's no time limit. When purchased, you are issued a serial number(s), which for all intents and purposes is permanent.

Subject: RE: Unable to open Sound Forge
Reply by: Markk655
Date: 9/1/2013 9:39:51 PM

In case support is still actively looking into this...

I used to be able to open up Sound Forge Audio Studio standalone or via Movie Studio. I don't use it SF very often, so I don't when it stopped working, but I can no longer open SFA Studio unless I run as admin. It also won't launch within Movie Studio 12 as well. This appears to be the same issue as in this thread. To help troubleshoot I include specs. It seems to be a registration issue (even though I have registered the software when it was initially installed).

Win 8 64 bit
Sound Forge 10 Audio Studio (tried both builds 178 and 245).
Movie Studio Platinum 12.


Message last edited on 9/1/2013 9:44:04 PM by Markk655.
Subject: RE: Unable to open Sound Forge
Reply by: ECB
Date: 9/3/2013 8:55:35 AM

Having to run Sound Forge 10 in administrative mode and no solution is why I did not upgrade to Sound Forge 11.

ed b

Subject: RE: Unable to open Sound Forge
Reply by: Markk655
Date: 9/9/2013 10:40:44 AM

So, there is no other workaround at this point...Does the same issue exist for SF 11?

Subject: RE: Unable to open Sound Forge
Reply by: spinear
Date: 9/27/2013 11:05:11 AM

I am having exactly the same problems for SF pro 11.
Any idea?

Subject: RE: Unable to open Sound Forge
Reply by: tpclapham
Date: 10/2/2013 2:58:16 PM

I'm having similar problems with Acid and Sound Forge compatibility. Everything was working fine until about two weeks ago-- Sound Forge wouldn't open anymore without logging in as Administrator, and Acid quit letting me use it as an editor. I get a "The specified audio editor cannot be opened" error message even though it worked fine previously.

I've been using Audacity as an editor for Acid with no problem in the interim but wonder why two Sony products can't get it together. The admin login window prompt for SF is aggravating as well.

Subject: RE: Unable to open Sound Forge
Reply by: SteveR1010
Date: 10/4/2013 11:36:11 AM

I just upgraded to SF11 from 10.

Problems:

1. I cannot drop files onto 11,
2. nor does Vegas 12 successfully allow the SF11 audio editor to open (it begins, but goes an further then the click next on the read about the elevated privileges page, then after my acknowledgement, proceeds with a windows question to allow it to run, then upon my ack it just disappears - 'never to be seen again'.),
3. and the start menu requires me to right click as administrator to get it to open, even though I am logged on as an administrator.

Additionally, I tried to uninstall SF11 (and the noise filter) both of which I could not because of some dll install error. I had to use an ioBit uninstall program to search for and delete left over files and registry entries (required for reinstall) . Nevertheless, the reinstall did not change things - all the same problems.

Subject: TO Peter (SonyPCH)
Reply by: TeeTime
Date: 1/21/2014 7:54:04 AM

Peter, like others in this forum I am having problems opening SF7 in SVP12. Although it used to open in SVP10, it no longer opens there either. I suspect it is a registry setting gone amuck. I have done all the troubleshooting tips discussed here and elsewhere to no avail. In August 2013 you said you were looking into this. I hope you can offer a suggestion to resolve this annoyance.

Thanks,
/jerry

Subject: RE: Unable to open Sound Forge
Reply by: YAUN
Date: 6/3/2014 10:28:44 PM

SF 11, Vegas 13, same problem as reported on June 26, 2013 by Caraelius and it appeared out of the blue after running for weeks. Just updating the record as it appears nothing is happening since it's been almost a year so hope and expectations are nowhere to be found.

Message last edited on 6/3/2014 10:31:00 PM by YAUN.
Subject: RE: Unable to open Sound Forge
Reply by: wobblyboy
Date: 6/4/2014 10:48:19 PM

I am also having the same problem. Just started today. It is a pain. I will try to contact Sony tomorrow. Vegas, Acid, Cd and DVD Arch open fine. Must have been a problem with recent update.

Subject: RE: Unable to open Sound Forge
Reply by: wobblyboy
Date: 6/4/2014 10:52:33 PM

Would it help to uninstall Sound Forge and re-dowload and re-install?

Subject: RE: Unable to open Sound Forge
Reply by: VsnMxr
Date: 6/26/2014 7:06:32 PM

Replying to SonyPCH who posted on 8/1/2013: "
We are looking at the need to run as admin issue.

Peter"

Ummmm, what happened with that? Did you guys forget about the problem? It's been almost a full year now since this problem arose. Still no fix. Why?

Subject: RE: Unable to open Sound Forge
Reply by: ShriekStudios
Date: 2/3/2015 7:53:27 PM

So.. is this dead or is there a solution? I'm experiencing the same problem.. 2 years after this thread started..

Subject: RE: Unable to open Sound Forge
Reply by: VsnMxr
Date: 2/5/2015 7:41:35 PM

I have the same problem. It appears Sony simply doesn't care. I think, like with Acid Pro, Sony has quietly abandoned Sound Forge, and is giving its customers the proverbial middle finger.

I filed a complain against Sony on this issue in 2014 with the Better Business Bureau. They kept saying "this is a known issue" but refused to answer when, or if, they were going to fix it - By the time I filed my complaint with the BBB, it had been over a year since this "known issue" popped up.

After I filed my complaint with the BBB, Sony did release a patch that did solve the problem for me - until now. Sony just released an "update" to SF11, and now, my program is back to the state it was in 2013! Same exact problem.

So far, Sony "support" has ignored my requests for help.

Subject: RE: Unable to open Sound Forge
Reply by: ChristoC
Date: 2/6/2015 3:32:49 PM


So you think SCS are doing this deliberately in order to wreck their own business?

I don't think so!

I think the real story is that Microsoft changed the OS and (depending on how you look at it...) broke or fixed some aspects, but left developers in the dark as they failed to communicate properly anymore - that is entirely the experience of another reputable audio application developer I know well; most of his communications with Microsoft are left unanswered. He had a "good relationship" with them until they released Windows 7......

Subject: RE: Unable to open Sound Forge
Reply by: pwppch
Date: 2/6/2015 9:55:03 PM

@ChristoC

Exactly! We are not ignoring this issue. It has proven a tough problem to solve. We are not doing this intentially.

The install team continues to look at the issue. It is very hard to reproduce. We have been reaching out to indivuals to help us to discover the cause.

We want to solve this, it is important. Not releasing a fix is not in our best interest.

Peter

Subject: RE: Unable to open Sound Forge
Reply by: VsnMxr
Date: 2/7/2015 12:32:13 AM

And this alleged problem with Microsoft is the customer's fault how?

Sony is NOT some mom and pop business. Common sense dictates that if Microsoft has done something that has screwed up Sony's software, Sony would adapt to it. If it doesn't know how to adapt to it or fix it, find someone who does! I mean, whatever the issue is, other companies seem to have either fixed it, or found a way around it (as speaking for myself, I only have this problem with SF11), so why can't Sony?

Common sense tells me Sony, a multi-billion dollar, worldwide cooperation, can get the attention of Microsoft if it wants to. I can't, but I bet Sony can! Especially if something Microsoft has done if effecting their software, which impacts Sony's customers, not Microsoft's. Again, common sense dictates that Sony would want to find a solution as quick as possible.

Surely a company as huge as Sony understands its hundreds of millions of customers around the world are not all computer experts, or developers. Most aren't. So its customers know nothing about some quibble between Sony and Microsoft. In other words, I paid money to Sony for my product, not Microsoft. I don't care about the internal politics of Sony or Microsoft - I just want what I paid for to work as advertised.

So are they doing this to "deliberately" wreck their own business. Who knows? I think many would argue they did that when they unceremoniously dropped Acid Pro 8, after promising an Acid Pro 8 upgrade.

It's that kind of guile that makes one wonder, just what the hell is wrong with Sony? Does Sony really care about its customers, or is it just stringing us along until it drops the rest of its unprofitable "home studio" division?

Subject: RE: Unable to open Sound Forge
Reply by: VsnMxr
Date: 2/7/2015 1:02:44 AM

@ SonyPCH Peter

I think people can appreciate that, but the problem for many people is simple:

It's been years now!

However, Sony did release a patch sometime in 2014 that did seem to fix the issue, at least it did for me. I'm guessing it was a patch, but honestly I don't know the difference between a patch and an update, if there is one. But something was done that seemed to fix the problem, at least for SFpro11.

But now with this latest update (Build 299), the problem has returned, at least for me, but apparently others as well as seen by the uptick on this forum.

So I thought the problem was fixed? It's only now, at least for Sound Forge Pro 11, build 299 (what I am running), that the problem has returned.

Surely Sony must have record of that "patch" and maybe it can use that again to fix the problem?

(I can't speak to as if other Sound Forge products ever had a fix or not)

Subject: RE: Unable to open Sound Forge
Reply by: Closet Geek
Date: 3/26/2015 10:53:09 PM

I went into the program file for Sony Sound Forge. Right clicked on the AudioStudio100.exe and went into properties. Clicked on the Compatibility tab, Clicked on Change Settings for All users, and checked box that says run this program as administrator. Saved changes of course. It allowed me to open the program from a desktop shortcut that I had created and update the program. I have not checked the sound for garble, but it appears to be working fine.

Subject: RE: Unable to open Sound Forge
Reply by: Avdi Grimm
Date: 10/15/2015 1:45:48 PM

Any news on this? I just ran into the same issue, and I'm now unable to open Sound Forge unless I run it as adminstrator. And as other posters have noted, this causes some real problems interacting with Vegas.

Subject: RE: Unable to open Sound Forge
Reply by: silvertone1938
Date: 10/15/2015 1:56:27 PM

There's a better workaround than running as admin posted on the SCS knowledgebase: https://www.custcenter.com/app/answers/detail/a_id/5176

It doesn't solve the issue permanently for me, but if and when the problem crops up again after a few weeks/months it just take a minute to run through the steps. Not ideal, but better than the run as admin issues and MUCH better than no workaround at all.

Subject: RE: Unable to open Sound Forge
Reply by: Phil Sayer
Date: 11/10/2015 3:55:29 AM

I did this a few weeks ago, and it worked fine. But the problem has abruptly returned. The only change to my PC prior to the problem coming back was installing an update to Adobe's PDF reader.

With a deep sigh, I'll go and do it again!

Subject: RE: Unable to open Sound Forge
Reply by: JJS
Date: 11/18/2015 7:08:12 PM

I just updated Windows 10 to the Fall update (Threshold2) and now not only is the problem back (Activation screen pops up unless you launch in Admin mode), but I can't delete that Registry folder based on https://www.custcenter.com/app/answers/detail/a_id/5176.

I'll attempt to uninstall SF11 and reinstall and see if that fixes the ability to delete that Registry folder.

JJS

Subject: RE: Unable to open Sound Forge
Reply by: billvo
Date: 1/3/2016 6:16:31 PM

Never had this problem until today, and it happened out of the blue. I am running Windows 10. Sound Forge was working, and then I got the activation popup. Tried running as administrator but couldn't drop files.

Did the registry fix and it worked OK, but I'm worried now it will happen again.

I'm astounded this problem is two years old and is still happening.

Subject: RE: Unable to open Sound Forge
Reply by: FixitMad0
Date: 1/5/2016 4:03:36 PM

I am wondering if Windows Updates are somehow messing around with program permissions, etc. I have seen at times other issues after getting Microsoft Windows updates. Especially with shared components like Visual C++, .NET framework. I am not saying this is the reason, but I have had issues in the past after getting the monthly Windows update.


Subject: RE: Unable to open Sound Forge
Reply by: jdaviscpa
Date: 2/8/2016 11:02:40 PM

I recently upgraded to SF Pro 11 from version 9, have been unable to start 11. It gets through the splash screen to the opening page, but stops responding at the first mouse click anywhere. Have been rattling back and forth with support to no good result. Have tried a great many suggestions, including run as admin, uninstall and reinstall multiple times, stopping all services and disabling all startup applications, renaming the plug-in file, and others I probably don't remember. Anyone having this problem besides me?

Subject: RE: Unable to open Sound Forge
Reply by: rraud
Date: 2/9/2016 10:23:23 AM

Fill in your profile's System Specs. (OS, hardware, ect.)

Subject: RE: Unable to open Sound Forge
Reply by: greg9876
Date: 2/16/2016 8:49:28 PM

I just had this happen again installing the iZotope DDLY Dynamic Delay and iZotope Vinyl plugins. After installing these plugins, I opened SF Pro 11 and then closed it. Later, when I opened SF Pro 11 again, I got the "elevated privileges" popup.

I wonder if there is a interaction between Sound Forge Pro 11 and the iZotope installer that is doing something to the registry.

Usually the SCSknowledgebase: "https://www.custcenter.com/app/answers/detail/a_id/5176" instructions work but this time regedit refused to delete the 11.0 folder with a "Error while deleting key" message. Finally, (thank the digital gods for google), I found a program called RegistrarHome that would delete the folder.


Message last edited on 2/16/2016 8:50:15 PM by greg9876.
Subject: RE: Unable to open Sound Forge
Reply by: Uwe
Date: 4/17/2016 5:40:03 AM

This helped me:

https://www.custcenter.com/app/answers/detail/a_id/5176/~/launching-sound-forge-on-windows-8,-8.1,-or-10-results-in-a-registration-of

Message last edited on 4/17/2016 5:40:28 AM by Uwe.
Subject: RE: Unable to open Sound Forge
Reply by: Smith111
Date: 6/21/2016 10:44:09 PM

^^ This worked for me!!

Subject: RE: Drag and drop Sound Forge issue (SOLVED)
Reply by: Sound of Sine
Date: 8/10/2016 4:07:31 AM

This has been playing on my mind for a couple of weeks now, trying to find the answer without tampering with the Windows registry and I honestly do not want to disable my windows metro apps just so I can drag and drop my media to Sound Forge.

So after some logic thinking, I've figured a work around solution, which is a bitwig of a cakewalk to do and now able to n ow push this disastrous 'disabled drag and drop' nonsense out the way without having to mess up my Windows.

>>> SOLUTION HERE >>>

Works with Windows 10 (Not sure about past Windows too but worth a try).
FYI: I use Sound Forge 10.

Hold the 'windows key' + 'R' to open the Run Command.

Not including the quote marks type:
'shell:sendto'

The 'Send To' folder window shall open.

Find the Sound Forge exe wherever you've installed it. Create a shortcut link to it and drag into the 'Send To' folder.

Now, right click on a media file (multiple selection works too) that you would normally drag and drop into Sound Forge and go to & click on 'Send to > Sound Forge'.

Your files will now open in Sound Forge.

NOTE:
If you've messed up your registry and you want your windows metro apps to work again then follow the below YT link to fix.

https://www.youtube.com/watch?v=Cayk9qsGuPo

Go Back