Community Forums Archive

Go Back

Subject: SF AS 10 suddenly requesting elevated privledges
Posted by: sellavisionmedia
Date: 2/27/2013 11:27:04 AM

I installed W8 about a month ago, and yesterday, I tried to run Audio Studio 10 and get an elevated privileges screen....I have removed 10, reinstalled and re-registered it and I keep getting the same result.....now can I eliminate this...I cant get AS10 to run at all...

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: jackn2mpu
Date: 2/28/2013 7:48:52 PM

Why did you install Win 8 when any version of SF is not certified to run on it? Should have stayed with Win 7 or whatever you had before. Bleeding edge is not necessarily a good thing.

Jack

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: alvester
Date: 3/22/2013 12:31:25 PM

I'm having the same exact same issue with Sound Forge 10 on Windows 8. I installed Win 8 and it's definitely much faster and more stable than Win 7 was but unfortunately I'm having the same issue with the message popping up that says "registration of sound forge pro 10.0 requires elevated privileges".

It will not pop up if I run Sound Forge in "Run as Administrator Mode" (right click on the SF icon to find this option). Run as Administrator mode will get the software to run but unfortunately this mode will NOT allow drag and dropping of files from Win 8's File Explorer to open said files up in SF. Win 8's File Exlporer only runs at Standard privilege settings even if you are running it from within an User account with Administrator privileges. This is a new "security" feature of Win 8 apparently but it throws a BIG monkey wrench into working with SF Pro 10 on Windows 8.

Once you do run SF pro 10 as “Run as administrator” on Win 8 the only way you can open files is from the Menu - File - Open dialogue. Drag and drop won't work.

While I was typing this up I got on the phone with Sony Creative support and the gentleman recommended that I create a fresh new user account solely for the purpose of registering a fresh install of SF 10. If I get the software to register and run effectively without having to select Run as Administrator he suggested to then log off the new user account over to my regular user account to verify if it is running ok. After that verification he said I could then delete the other new user account.

He said he would be sending me instructions via email. I’ll post back about my experience with success or failure.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Larry Clifford
Date: 3/24/2013 10:31:00 AM

alvester, please post those instruction for the benefit of everyone.

We look forward to hearing about your results.

As for me, I am going from Windows XP Pro to Windows 7 Professional SP-1 64-bit. Mice rule!

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: myeck
Date: 4/6/2013 5:06:20 PM

I also am now having this problem. This machine started off running XP-64bit (I know, I know) but there were constant driver problems. Then I was received an upgrade copy of Vista (I KNOW, I KNOW) which I installed last fall (and the driver problems continued), and then I switched to W8 in January during the Microsoft promotion.

Through all that, SF10 worked like a champ, and the switch to W8 finally cured my driver problems and everything worked and there were fluffy bunnies and kittens for everyone.

Until two days ago. Suddenly SF is demanding elevated privileges. Ugh.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: chudson
Date: 4/10/2013 8:20:49 AM

Same here, SF10 has been working great . Just last day or so I get the elevated privilege must me registered message. The registration app triggers UAC which I allow, but it neither registers the software or fixes any issue. SF10 won't open at all now, continuous loop of registration app followed by nothing.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Kit
Date: 4/10/2013 6:25:04 PM

This is just a guess but what I would try is completely removing Sound Forge including cleaning the registry and then before reinstalling change your user account to admin, Then install Sound Forge and register it. Run it at least once and then put the user account back to regular level. This has worked for me with other misbehaving software on Windows 7. It may work for Windows 8.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Geoff_Wood
Date: 4/10/2013 10:18:21 PM

I actually think it's nothing to do with SF but is a Win update. I have all sorts of apps suddenly doing something similar on a Win7-64 PC.

geoff

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Tollkuhnator
Date: 4/19/2013 11:44:18 PM

Same problem here starting with build 245 on Windows 8. I can run it as Administrator, but when I try running it normally it asks for elevated privileges. Clicking OK causes the program to terminate. Have already tried uninstalling and reinstalling.

Message last edited on 4/19/2013 11:46:11 PM by Tollkuhnator.
Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: joegab
Date: 6/11/2013 3:26:32 PM

I am having exactly the same problem on Win 8 (SF 10 MUST be run as Administrator, otherwise it does not run).

I asked support, and they are telling me that this product "should" be run as the Administrator account (and seems NOT in my normal account, which HAS administrative privileges).

So, does someone found a solution for this?
Thank you,
Giorgio

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: ECB
Date: 6/14/2013 8:57:51 AM

I was having the same problem with win 7. Don't know if it will solve the problem with Win 8.This is the answer from support:

The administrative rights issue is very common with Windows 7. Since all Sony Programs require administrative privileges to run properly. To fix this issue so you are not constantly prompted for permissions please do the following. Right click the icon of the program to launch it, but without launching it go down to properties in the drop down list and open the properties window. Go to the Compatibility tab and down at the bottom you will see a check box that says 'Run as an administrator' select this check box and also hit the 'change settings for all users' button below. Another window will open and again, select the check box down at the bottom that says 'run this program as an administrator'. Then select ok and that will close the second window. Hit Apply on the properties window and ok to close it. Then launch the program. This should make it so that all users no matter which account their on will be able to run the program without being prompted for elevated privileges.

I just noticed I can not open an audio event with SF 10 from within VP12.

EB

Message last edited on 6/14/2013 8:59:18 AM by ECB.
Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: joegab
Date: 6/16/2013 6:47:54 AM

I can't explain what happened, but in this PC SF10 started again to work without the "administrator" problem (since a couple of days). Simply .... now it runs as it did before.

I didn't modified anything ..... I don't know.

Only thing that I noticed, is that the computer received some automatic updates (win 8 x86) .... and that's all....

Let's keep finger crossed.

Giorgio

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Geoff_Wood
Date: 6/19/2013 10:44:53 PM

Probably the update that fixed the previous update that caused things to go ape before !

Geoff

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: xercxes
Date: 9/23/2013 9:06:55 AM

Bravo ECB......thank you for saving me some time!

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Daniel Peterson
Date: 11/5/2014 5:12:03 PM

ECBs explanation totally worked for me in Windows 8.. Thanks ECB!

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Kit
Date: 11/5/2014 7:56:28 PM

Since when have all Sony programs required Admin privileges to run? I would not accept such a solution from support. Total avoidance by support staff.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: kryten
Date: 11/5/2014 10:20:46 PM

Every Sony product I've used since Win 7 requires admin rights. To this day, I still use SF 4.5 with admin rights (and CDA 4) and it works fine for what I do. It's a Microsoft thing and not a Sony thing. What MS allows to run as an admin has changed as of Vista.

Message last edited on 11/5/2014 10:22:48 PM by kryten.
Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Kit
Date: 11/6/2014 4:44:34 PM

I've never run any Sony product with Admin rights. I consider running programs with such rights a security risk. There's no way it should be necessary. As far as I know Microsoft made it easier to run programs with Admin rights but I haven't heard about any changes to Admin requirements. Any links to support your claims? I still think this is a cop out by Sony support. If a product requires admin rights in order to work that should be listed as a requirement. Never seen it for Sound Forge.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: kryten
Date: 11/6/2014 9:53:28 PM

You probably have UAC turned off. http://www.sevenforums.com/general-discussion/20250-why-do-i-need-run-administrator.html

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Kit
Date: 11/7/2014 6:40:17 PM

Of course I don't have UAC turned off. The whole point is to avoid compromising the security of a system. Having to run programs like Sound Forge as Admin is unacceptable.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: kryten
Date: 11/7/2014 7:14:40 PM

Good luck. I have no problem with running as admin. Personal preference that let's me get done what I need to do.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: Kit
Date: 11/8/2014 9:16:05 AM

Thanks, but If you are running as Admin then you need good luck more than I. it isn't necessary using Windows 7 64 bit and shouldn't be necessary using Windows 8. Why risk compromising security? For audio and video programs the need to run as admin really is complete nonsense.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: chucky
Date: 1/21/2015 1:42:58 AM

Thanks ECB, that's what we need. :)

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: TFab
Date: 12/11/2015 10:59:44 PM

Thanks for leaving your post. It was very helpful and worked on this frustrating topic! I am using SF Pro 11 on a New Windows 10 Laptop. SF worked properly for several weeks before I had this issue. Issue now resolved thanks to your post.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: geg
Date: 5/4/2016 1:54:46 AM

So many thanks! I have been pondering this one since Windows 8 launched. Tried all sorts. There you have it. All the crock work arounds posted and your reply/solution spot on to the letter. Merci.

Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: xcarles
Date: 5/24/2016 4:23:08 PM

Someone knows how to make drag and drop works when SF11 on W10 functions as board administrator?


Subject: RE: SF AS 10 suddenly requesting elevated privledges
Reply by: PCNUT
Date: 6/4/2016 4:18:18 AM

I followed this instructions for Windows 10 64 bit. They worked fine, thank you.

Go Back