Community Forums Archive

Go Back

Subject: Track Buffering
Posted by: mike_in_ky
Date: 1/2/2016 9:20:17 PM

Among my uses of Acid Music Studio 9, I do covers of songs. Over the past several months, I've been experiencing a frustrating problem that manifests itself as follows.

I start a new project, add a backing track .wav file, add an audio track, record vocals, add another audio track, record more vocals or instrument, and so on until I have the number of voices and/or instruments that I want, usually 8 - 15 tracks. At different points in each project (it varied from project to project), as I would be recording events on a track, when I would click "stop" on the transport to stop recording, Acid would freeze up and program header would display "Not Responding". Then I would have to use Task Manager to close the program. This got to be very frustrating and annoying especially if I had another singer working with me, trying to re-record vocals several times to get it to work. This would happen in Windows 7 and Windows 10 and on 2 different computers. My desktop computer is a Gateway DX-2370 (AMD quad core running at 2.1 GHz with 12 GBytes RAM) and my laptop is an HP G62-222 (AMD dual core running at 2.4 GHz with 6 GBytes of RAM). Also, I tried using ASIO-4ALL and Classic Windows audio drivers with the same results. In all the years I've used Acid (beginning with version 6), I had never experienced this problem until about 4 months ago. I can't say I recall that anything changed on my systems at that time. I even tried uninstalling/re-installing the program, to no avail.

Finally having enough of it, I started investigating the cause and stumbled upon something that has seemed to have solved the problem (on the surface anyhow). In "Preferences-->Audio Device", I unchecked "Enable Track Buffering", applied it and closed preferences. That solved the problem in all cases on both computers and both Windows versions.

I don't FULLY understand what track buffering does, but AMS 9 (Build 40) installs with that option enabled (0.25 seconds) so buffering must be important.

Can someone please shed some light on the problem I experienced and offer other possible solutions so that Track Buffering can be enabled if it were necessary from time to time? From what I've described above in my workflow, is Track Buffering even necessary for what I'm doing? If it is, what kinds of symptoms should I be on the lookout for because it's not enabled?

I would appreciate some insight and advice.

Message last edited on 1/2/2016 10:27:15 PM by mike_in_ky.
Subject: RE: Track Buffering
Reply by: ClipMan
Date: 1/3/2016 10:46:34 AM

From the Help files:

"Select this check box and drag the Track buffering slider if you want to adjust the amount of audio that is prerendered ahead of the cursor position. When the check box is selected, a separate processing thread is used to render audio from tracks. On multiprocessor or multicore computers, a thread will be created for each logical processor. When the check box is cleared, a single processing thread is used to render audio from tracks and busses."

From a Forum search:

"Subject: RE: Track buffering in Acid 6 pro.
Reply by: SonyMLogan
Date: 11/16/2006 12:54:32 PM

Bo,

The advantages of track buffering:

1) Projects are less likely to gap at low latancies.
2) Track buffering allows acid to take full advantage of multi-processor/core systems.

The 0.25 second default buffering amount may be a little too conservative for your needs. Try cranking the buffering amount down to the minimum and if that plays ok, I’ll bet your GUI meter issues are reduced significantly.

- Matt Logan."

Subject: RE: Track Buffering
Reply by: mike_in_ky
Date: 1/3/2016 12:46:24 PM

I'll give it a try and see what happens. I had read the Help file about track buffering, but still was a little unsure.

Thanks for your reply and explanation, Matt.

Go Back