Community Forums Archive

Go Back

Subject: SpectraLayers 3 Pro crushing workflow problem
Posted by: beatdriver408
Date: 3/19/2015 12:49:35 AM

The fact that SpectraLayers automatically attempts to set your sound card to the sample rate of the file that you open is a crushing workflow impediment. I will typically have ableton open at 96k/24bit, and need to edit a sample. When I open the sample(which is 44.1khz/24bit),SpectraLayers tries to switch the sample rate of my card and locks up both SpectraLayers and Ableton.

SpectraLayers should behave as virtually every other audio program I use, and allow the sample rate of the ASIO card be independent of the source material. I do understand you can resample the project and such but the fact that it just opens existing files without any care for the current system settings is a real problem.

RME UFX driver 1.059, hardware rev 357.

Subject: RE: SpectraLayers 3 Pro crushing workflow problem
Reply by: ChristoC
Date: 3/19/2015 2:15:03 PM

I think there is some deep ASIO problem with the new SL Version 3.0.17

Asio Drivers: Version 3.0.17 does Play; just opening a file and pressing play = no sound / no sign of life.

I have to use WASAPI drivers....

Both previous SL Versions 1.0.21 & 2.1.32 work fine with ASIO drivers every time with same file on same PC.
All other ASIO apps (SoundscapeEditor, VegasPro, SoundForgePro, MelodyneEditor, ProTools) work fine all the time.


Solid State Logic / Soundscape MX4 soundcard + Asio drivers


Message last edited on 3/19/2015 3:50:53 PM by ChristoC.
Subject: RE: SpectraLayers 3 Pro crushing workflow problem
Reply by: divideframe
Date: 3/19/2015 5:00:38 PM

In no circumstances should driver calls crash other applications, so I would suspect a problem with the driver itself (similar problems with the rme ufx asio driver were reported here http://www.native-instruments.com/forum/threads/kontakt-5-2-crashes-when-changing-sample-rate.197090/ ).
Regarding your problem, in theory SpectraLayers only use samplerates which are reported as available by the driver for playback/record (doing realtime conversion if needed), however I suggest to switch to Wasapi (at least in SpectraLayers, not sure if Ableton support that), which is a more modern way to address the audio hardware on Windows and should not have such conflict.

Message last edited on 3/19/2015 5:05:36 PM by divideframe.
Subject: RE: SpectraLayers 3 Pro crushing workflow problem
Reply by: ChristoC
Date: 3/19/2015 7:28:37 PM

If I use WASAPI / MME drivers rather than ASIO the output signal is 11dB lower, with any version of SL, even with Windows Audio levels set to 100.

That's the reason why I prefer ASIO; why don't your ASIO drivers work in my system with SL V3?

- Win7_64

Message last edited on 3/19/2015 9:52:20 PM by ChristoC.
Subject: RE: SpectraLayers 3 Pro crushing workflow problem
Reply by: divideframe
Date: 3/20/2015 4:59:39 AM

I emailed you regarding your problem.

Subject: RE: SpectraLayers 3 Pro crushing workflow problem
Reply by: ChristoC
Date: 3/20/2015 9:04:24 PM


Thanks Robin; I have replied....

Subject: RE: SpectraLayers 3 Pro crushing workflow problem
Reply by: ChristoC
Date: 3/27/2015 4:07:44 PM


Update:

Seems SLP3 was trying to grab all 127 ASIO Streams available from my SSL MX4 soundcard; that failed if some of those streams were already in use; after we worked out that was occurring, Robin sent me a version which utilizes only the required streams according to SLP3's Input/Output Channel Mapping , so I can now use ASIO Drivers :-)

Thanks for amazing support!



Go Back