Community Forums Archive

Go Back

Subject: Save As... command ignoring characters after dot
Posted by: Phil Sayer
Date: 12/2/2013 3:40:41 PM

Windows 7, SF Pro 11 (upgraded from SF 9)

In SF 9, if I want to save a file as, for example, 02.04.wav, I would type "02.04" and SF added .wav when it saved the file.

But now, in SF11, if I do that, it ignores (deletes, in effect) any characters after the dot. So in the example above, it saves the file as 02.wav

However, I've discovered that if I type the dot in the File name box myself, SF11 will add the correct extension, in this case "wav" - it just won't add the dot!

I'm sure I will eventually get used to having to add the dot at the end of every file name before I save each file, but we often edit hundreds of files in a session, and if there is a way to go back to the "old" way, where SF adds the extension AND the dot, I'd be happy to know how!

Tech support (live chat) don't know, and I've looked through all the Help files and this forum. I have made sure that it isn't a "saving to a network drive" issue, but it isn't - this occurs wherever I try to save the file.

I've worked on this for over an hour, looked at settings galore, but no joy - any help will be VERY gratefully received! Thank you.

Subject: RE: Save As... command ignoring characters after dot
Reply by: roblesinge
Date: 12/2/2013 3:46:14 PM

This is also the case in SF 10. I don't think there is a fix for this. I've just gotten used to adding the "." whenever it is called for.

Rob.

Subject: RE: Save As... command ignoring characters after dot
Reply by: Phil Sayer
Date: 12/2/2013 4:05:14 PM

Thanks, Rob. I leapfrogged 10, so this is new to me.

Has anyone made Tech Support aware, do you know? It might be worth adding to the next wish list for any possible new release.

Subject: RE: Save As... command ignoring characters after dot
Reply by: scott2eh
Date: 12/15/2013 1:48:40 PM

This is probably not what you want to hear so you can ignore me if you want but I thought I'd say it anyway:

You should never use a . in a file name. It's one of the absolute standards in file naming in Windows. In fact, this is exactly how a lot of viruses hide. One of the worst, Ransomware, uses this exact method to pretend to be a pdf or jpg file. The real extension ".exe" gets hidden and people run the program thinking it's just a picture.

It is an extremely bad idea to use a . in a file name anywhere except just before the file extension so I highly advise against it. It's just as easy to use a - and you avoid a lot of potential problems. I've seen a lot of people lose a lot of important files simply by developing bad habits like this that lead to disaster. It's always better to work with the operating system instead of against it.

Scott

Subject: RE: Save As... command ignoring characters after dot
Reply by: roblesinge
Date: 12/16/2013 8:07:45 AM

I agree that this is not a good practice. However, some of us have clients who insist on using extra '.' chars in their filenames. Lots of my clients are using legacy phone systems (some where the target OS is not Windows) that require such naming conventions.

Rob.

Subject: RE: Save As... command ignoring characters after dot
Reply by: Phil Sayer
Date: 2/25/2014 11:00:21 AM

Hi Scott,

I admit I was unaware of the Windows file-naming convention, so I thank you for the info.

But, like Rob, I'm at the mercy of customers - it is they who usually provide the file-naming regime, along with the text for me to speak.

What is the preferred option? Would the underscore would be better?

Cheers,

Phil

Subject: RE: Save As... command ignoring characters after dot
Reply by: kryten
Date: 2/25/2014 9:00:01 PM

Put the entire file name in quotes (i.e "02.04.wav").

Subject: RE: Save As... command ignoring characters after dot
Reply by: Geoff_Wood
Date: 2/26/2014 11:49:47 PM

Easy workaround - use a 'dash' . Dot can be a bit confusing for the file system and allowing them was a bit of a fudge.

geoff

Message last edited on 2/26/2014 11:50:46 PM by Geoff_Wood.

Go Back