Community Forums Archive

Go Back

Subject: VSTi track voices revert to default
Posted by: PALomino
Date: 11/5/2011 12:49:15 PM

I'm working with several VSTi soft synths in a project...all freeware, some are Krakli, some from TAL, etc. After I close and re-open a project, I find that the voice on each VSTi goes back to the first one in its drop-down menu. The track headers themselves do show the voice I'd selected, but the soft synth properties are back to the default voice. When I reselect the desired voice in the soft synth properties, The voice retains any parameter adjustments I'd made (attack, resonance, etc.) I don't have this problem with the DLS soft synth or with Kompakt or ARIA. I've tried activating Synth Control of Program change after my voices are set the way I want them, didn't help. This is Acid Pro 7 on Windows 7 x64, same problem occurs on Win XP SP3. Thanks for any replies.

Subject: RE: VSTi track voices revert to default
Reply by: cyrilfb
Date: 11/7/2011 12:53:15 PM

This may be too obvious but, when I first used Music Studio, I had that problem. It turned out to be that I forgot to assign a different midi channel to each soft synth.

Hope this helps,
Cy

Subject: RE: VSTi track voices revert to default
Reply by: PALomino
Date: 11/8/2011 9:57:32 AM

alas, that didn't help, but thanks. My other, registered soft synths seem to be doing fine so I think this is a case where these freeware plug-ins just weren't tested with Acid...

Subject: RE: VSTi track voices revert to default
Reply by: collinsylex
Date: 11/10/2011 8:18:49 PM

I just experienced the exact same issue!

I had used the VSTi version of Sytrus (ya the fruity loops synth), and when i returned to open the project a week later, it had switched itself from a deep bass preset to a string ensemble somehow... I also had NI Massive VSTi in the same project and it seemed to keep its settings fine...

its been ages since i used acid for midi programming but i decided to give it another go with that one project.. dangit, something had to go wrong! lucky for me I was able to sherlock holmes my way back to the original sound as i had no idea what it was originally set at, I only knew that the patch i had to re-find made a very nice bass!... it was a bit nervewracking doing this infront of the client who LOVED the way it had sounded on the original bounce i gave him a week before...

I just checked the project again now(after finally fixing the preset setting last night), and its still opening up the string ensemble patch instead of bass... either i have to learn what went wrong or remember that bass patch name forever incase that track will ever need further fixing! perhaps i should just bounce the part or try freeze it

im on a windows 7 x64 i7 desktop


Subject: RE: VSTi track voices revert to default
Reply by: PALomino
Date: 11/13/2011 5:28:55 PM

collinsylex, you say you have to remember the bass patch name...are you not seeing it in the track header? That's how its working for me, but it's not communicating with the soft synth properties somehow. So I can find the voices for each soft synth easily, but it's cumbersome to have to set them manually each and every time I re-open a project...

Subject: RE: VSTi track voices revert to default
Reply by: chucky
Date: 1/8/2012 2:27:51 PM

I am also getting bored with this reversion of vst presets, does Sony expect us to write little lists down to keep and refer to every time we open a project?
Or maybe they expect us to buy acid and not use it.'Doubblyattee, eff.'

Go Back