Community Forums Archive

Go Back

Subject: Loading problems on new windows 7 pc
Posted by: K Sines
Date: 11/23/2011 9:33:04 AM

Installled Sound Forge Pro 10c on new windows 7 64bit pc. Program loads but immediately says program has encountered a problem and has to shutdown. I have checked "Run as Administrator" and tried running in XP compatible mode - no help! I have tried most of the things from the Knowledgebase but no change. I have Vegas Pro 10 installed and that runs fine as well as DVD Architect 5. Any ideas as to why sound forge will not run?
Thanks

Subject: RE: Loading problems on new windows 7 pc
Reply by: Bustluvr
Date: 11/26/2011 6:40:00 AM

Hi have you fixed your problem with sound forge? im having same problem Thnx

Subject: RE: Loading problems on new windows 7 pc
Reply by: Stephen57
Date: 11/27/2011 12:53:22 PM

The problem is definely an issue with SF and Win7 64 bit. I've been searching for answers and have contacted support concerning the issue, however no one seems to know how to fix this bug,
I have been a long standing customer of Sound Forge Pro and I am very close to moving to a different software and canning Sony completely. It's a shame, as SF Pro has always run perfectly on other operating systems but refuses to work under Win7 64 bit.
Support emailed me back and gave absolutely NO help to solve this issue. I figure I'll give them to the end of Dec to fix the issue, or lose this customer to another software.

Message last edited on 11/27/2011 12:53:44 PM by Stephen57.
Subject: RE: Loading problems on new windows 7 pc
Reply by: K Sines
Date: 11/28/2011 5:15:45 PM

No. I only get auto-responses from Sony about Vegas. I have tried many of there tips, but to no avail. I wish we could get some kind of resonse. thanks

Subject: RE: Loading problems on new windows 7 pc
Reply by: Bustluvr
Date: 12/1/2011 10:13:17 PM

Hey stephen57 what software are u thinking about going to ,instead of SF? Im just about fat up with SF. I too have always used SF with no problems. THNX

Subject: RE: Loading problems on new windows 7 pc
Reply by: DaveGee
Date: 12/2/2011 1:40:23 AM

Samplitude and Wavelab are both very professional applications - incl. good support. ;-)

Subject: RE: Loading problems on new windows 7 pc
Reply by: Pcamp
Date: 12/6/2011 9:02:18 AM

Sound Forge 9 will not run on Win 7 either - there should at least be some comment from Sony about the situation.

Subject: RE: Loading problems on new windows 7 pc
Reply by: kryten
Date: 12/6/2011 9:03:39 PM

SF9 does not support Windows 7. Officially, only 10 does, and I think that's the lone reason it was released. There wasn't anything in it that compelled me to upgrade. Since then, I'm still running 4.5 on Windows 7 without issues. Run the installer as Admin (as well as updates), and run the program as Admin. No problems at all so far. :)

Subject: RE: Loading problems on new windows 7 pc
Reply by: Pcamp
Date: 12/7/2011 9:10:57 AM

Thanks! will try that.

Subject: RE: Loading problems on new windows 7 pc
Reply by: Stephen57
Date: 12/16/2011 10:15:28 AM

Bustluvr,
I'm still unsure what software I will be going to. I am looking at several and will let you know what I come up with.
This is truely a sad situation, as I have been a SF Pro user for years, purchased all the updates and have invested alot of money into the software. It seems SF Pro had always worked without flaws with other 64bit operating systems, but it just does not work properly under Win7 64 bit and Sony will just not admit that there is a problem, or offer a reasonable solution.

Message last edited on 12/16/2011 10:17:41 AM by Stephen57.

Go Back